HomeTroubleshootingAll Products: Startup"Object variable or With block variable not set" (Windows 8)

2.70. "Object variable or With block variable not set" (Windows 8)

Applies to: Palisade add-ins for Excel, releases 5.7 through 6.1, running in Windows 8 or 8.1

When I launch @RISK, I get

Object variable or With block variable not set

followed by

Run-time error '-2146232576 (80131700)':
Automation error

If I try opening Excel and then Risk.xla within Excel, I get the same thing.

@RISK 5.x and 6.x require Microsoft .NET 2.0 to run, but Windows 8 does not include that version. In Windows 8 and 8.1, to get .NET 2.0 it's necessary to install .NET 3.5.

If you have Windows 8.1, the @RISK 6.2.0–6.3.1 installers will install .NET for you; for earlier @RISK installers see Installing Palisade Software 6.0 or 6.1 in Windows 8.1.

If you have Windows 8 (not 8.1), the @RISK 6.1.1–6.3.1 installers will install .NET for you; for earlier @RISK installers see Installing Palisade Software 5.7 or 6.0 in Windows 8.

See also: There are other possible causes for this message. See All Articles about "Object variable or With block variable not set".

Last edited: 2016-02-23

This page was: Helpful | Not Helpful