HomeTroubleshootingAll Products: Startup"Object variable or With block variable not set" (Windows 7 and Vista)

2.69. "Object variable or With block variable not set" (Windows 7 and Vista)

Applies to:
Palisade add-ins 5.x–7.x for Excel, running in Windows 7 or Vista.

This may apply to Windows 8 and Windows 10 also, but we don't have any confirmed cases.

When I launch @RISK, I get

Object variable or With block variable not set
Run-time error '-2147024894(80070002)'

If I try opening Excel and then Risk.xla within Excel, I get the same thing.

@RISK 5.x and 6.x require Microsoft .NET 2.0 to run, and @RISK 7.x requires .NET 4.x. From the error number, it looks like your copy of .NET is corrupt. If you have .NET 2.0 SP2 or later, or .NET 4.x, you can download and run the Microsoft .NET Framework Repair Tool

If you have an earlier build of .NET 2.0, please follow the command-line procedure in How to repair the .NET Framework 2.0 and 3.0 on Windows Vista. (Although the article title says "Vista", the text indicates that the procedure also works for Windows 7.) If that is not sufficient, please follow the additional procedure in that article to repair the registry entries.

See also: There are other possible causes for this message. See All Articles about "Object variable or With block variable not set".

Last edited: 2016-11-23

This page was: Helpful | Not Helpful