HomeTechniques and Tips@RISK 6.x/7.x with ProjectsSending Confidential Projects to Palisade (Scrambler)

11.19. Sending Confidential Projects to Palisade (Scrambler)

Applies to:
@RISK 6.x/7.x
@RISK for Project 4.x

The technical support representative needs to see my project to solve a problem I reported, but I can't send it because it's sensitive. What can we do? Is there some way to obscure or hide the task names?

Yes, you can save the project under a new name and scramble all the task names. Because of the co-ordination with Excel, instructions for @RISK 6.x/7.x are a little different from instructions for @RISK for Project 4.x.

Caution: Once scrambled, the task names cannot be unscrambled. Therefore, save the project(s) under different name(s) now.

For @RISK 6.x/7.x:

You'll scramble the task names in Microsoft Project, but you need a few extra steps to synchronize the scrambled names with your Excel file.

  1. Open @RISK, and open your Excel model. @RISK will open your project for you, as usual.
  2. Click into Microsoft Project and click File » Save As to save the file under a new name.
  3. @RISK will sense that you changed the MPP file name, and will prompt you to save the Excel file. Use File » Save As, not plain File » Save, and use a name consistent with the new name of the MPP file.
  4. Close Excel. @RISK will close Microsoft Project for you.
     
  5. Double-click your project(s) to open them in Microsoft Project, not @RISK.
  6. Press Alt-F11 to bring up the VBA editor window.
  7. Insert a module in one of the open projects (right-click on Microsoft Project Objects and click Insert » Module).
  8. Paste in the macro code below, from Sub to End Sub inclusive.
  9. Press F5. The task names in all open projects will be scrambled.
  10. Right-click on the module you created and select Remove Module. When asked whether to export before deleting, answer No.
  11. Close the Visual Basic Editor window. Save the project(s) and close Microsoft Project.
     
  12. Reopen @RISK and open your latest Excel file. After it finishes linking with your project, in @RISK click Project » Sync Now to bring in the scrambled task names.
  13. Save the Excel file, and close @RISK.  Send the Excel file and the MPP file to Palisade.

For @RISK for Project 4.x:

  1. In Microsoft Project, not @RISK, open the project(s) where you want to scramble task names.
  2. Save the project(s) under different name(s).
  3. Press Alt+F11 to bring up the VBA editor window.
  4. Insert a module in one of the open projects (right-click on Microsoft Project Objects and click Insert » Module).
  5. Paste in the macro code below, from Sub to End Sub inclusive.
  6. Press F5. The code should run and the task names in all open projects will be scrambled.
  7. Right-click on the module you created and select Remove Module. When asked whether to export before deleting, answer No.
  8. Close the Visual Basic Editor window. Save and close the project.

Here is the code of the macro:

Sub scrambleNames()

    ' This macro scrambles all task names in all open projects to make them
    ' unidentifiable.  Caution! The process cannot be reversed.

    On Error Resume Next

    Dim thisProject As Project, thisTask As Task
    Dim i As Long, randomName$

    For Each thisProject In Application.Projects
      If Not thisProject.ProjectSummaryTask Is Nothing Then _
          thisProject.ProjectSummaryTask.Name = String(10, Chr$(65 + (Rnd * 25)))
      ' The above If statement should be one long line.
      For Each thisTask In thisProject.Tasks
        randomName$ = ""
        For i = 1 To 10
          randomName$ = randomName$ + Chr$(65 + (Rnd * 25))
        Next
        thisTask.Name = randomName$
      Next
    Next

End Sub

Additional keywords: Scrambler, scrambler utility

Last edited: 2015-09-01

This page was: Helpful | Not Helpful