HomeEnd User SetupBefore You InstallWindows and Office Versions Supported by Palisade

1.1. Windows and Office Versions Supported by Palisade

International language versions of this article:

Which software platforms or operating systems are supported by Palisade?

Palisade's latest release, 7.6.0, is supported on Microsoft Office 2007 and newer, running on Windows Vista and newer. For older releases, see the compatibility charts below.

Please note: Some functions in our software may seem to work in some Office or Windows version that are not supported. But some functions will not work, or not work correctly, not necessarily with an obvious failure mode. We strongly recommend against running our software with unsupported Office or Windows versions, and we cannot assist with troubleshooting on unsupported platforms.

If you have an older version and need to upgrade for compatibility with Microsoft Office or Windows, please see Upgrading Palisade Software. Customers with a current maintenance agreement can receive the upgrade to our latest versions at no charge; others please contact your Palisade sales manager.

Hardware:

Please see Hardware Requirements or Recommendations.

Microsoft Office Versions:

Palisade products with these version numbers require Microsoft Office for Windows to be installed on the same computer. Mac users, please see @RISK on the Apple Mac. Lotus, OpenOffice, LibreOffice, and StarOffice products are not supported.

Palisade version:7.67.0
7.5
6.3
6.2
6.1
6.05.75.5.15.5.0
5.0
4.5.7
1.0.9
4.1.4

(1)With Office 365 or Office 2019, we strongly encourage you to upgrade to the latest release of Palisade software for full compatibility. For Office 365 deployments, see Office 365 with Palisade Software.

(2)With @RISK 7.0 only, if you have Project 2007 you may need to apply the patch mentioned in this article.

(3)@RISK for Project 4.1.4 works with Project 2000–2003; 4.1.4r2 works with Project 2000–2007; and 4.1.4r3 works with Project 2003, 2007, and 32-bit 2010. To check your sub-version of @RISK for Project within 4.1.4, navigate to the Palisade installation folder, then to subfolder RISKPJ41, and double-click the Version History file.

Office 365 Excel
(except pre-release and "Office Insider" builds)
(1)(1)       
Excel 2019(1)(1)       
Excel 2016       
Excel 2013 32- or 64-bit      
Excel 2010 64-bit    
Excel 2010 32-bit   
Excel 2007 
Excel 2003   
Excel 2002/XP     
Excel 2000     
Office 365 Project
(except pre-release and "Office Insider" builds)
(1)(1)       
Project 2019(1)(1)       
Project 2016, build
16.0.4229.1002 or newer
       
Project 2013 32- or 64-bit      
Project 2010 64-bit      
Project 2010 32-bit    (3)
Project 2007(2)    
Project 2003      
Project 2002/XP        
Project 2000        

Notes:

  • In releases 6.0 and newer, one Palisade installer works with both 32-bit Excel and 64-bit Excel. Excel is required; Project is optional.
  • See also: Recommended Option Settings for Excel.

Windows Versions for End-User Software:

(For license server software, please see License Server System Requirements.)

Palisade version:7.5.2
7.6
7.5.1
7.5.0
7.0.1
7.0.0
6.3
6.2
6.1
6.0
5.75.5
5.0
@RISK for
Project
4.1.4r3
4.1.4r2
4.1.4
RDK/BDK/
EDK/RODK
4.1.2
Windows 10 (except
Windows Insider builds)
    
Windows 8.1   
Windows 8 
Windows 7
Windows Vista
Windows XP 
Windows Server See notes below.
Windows RT Not supported.

Notes:

  • Windows Server versions are not listed in the chart, because we have not done extended Quality Assurance of our end-user software with any Windows Server version. However, we are not aware of any incompatibilities between our end-user software and Windows Server 2008, 2012, or 2016.
  • Vista and newer: Right-click the installer and select Run as Administrator; simply double-clicking may not work. After install and activation, the applications do not need admin rights.
  • All of our installers work in 32-bit and 64-bit Windows; but the RDK, BDK, EDK, and RODK must run in 32-bit processes. In 64-bit Windows, all products install in C:\Program Files (x86).
  • Windows 8.1 with our 6.0 and 6.1 installers: Please see Installing Palisade Software 6.0 or 6.1 in Windows 8.1 before installing.
  • Windows 8 with our 5.7 and 6.0 installers: Please see Installing Palisade Software 5.7 or 6.0 in Windows 8 before installing.

If you have a system with a standalone or enterprise version of our software, before you upgrade Windows, please deactivate the software to preserve the license; then reactivate it after upgrading. See Transferring Standalone Software 6.x/7.x to a New Computer or Transferring Standalone Software 5.x to a New Computer for the transfer procedure.

Windows Versions for License Server Software:

Starting with release 7.5.2, our license server software requires Windows Server 2008 or newer, or Windows 7 or newer.

UNIX:

At the present time, Palisade products are not supported on Linux or any other flavor of UNIX.

Additional keywords: Compatibility, Version

Last edited: 2018-11-26

Downloads

This page was: Helpful | Not Helpful