HomeTécnicas e DicasPrinter Friendly Version

Técnicas e Dicas

1. Dicas para todos os produtos

1.1. Obtendo o melhor desempenho do Excel

Available in English: Getting Better Performance from Excel
Disponible en español: Conseguir un mayor rendimiento de Excel

Aplica-se a:
@RISK e outros suplementos da Palisade para Excel 

Pergunta:
Quanto do tempo de cálculo no meu modelo é gasto pelo Excel? Posso fazer minhas planilhas do Excel calcular de forma mais eficiente?

Resposta:
O impacto varia. @RISK (Particularmente RISK Optimizer), Evolver, PrecisionTree com árvores vinculadas, e TopRank são os mais afetados pela velocidade de cálculo do Excel.

  • @RISK e TopRank recalculam todos as pastas de trabalho abertas ("Recálculo do Excel"), uma vez por iteração.
  • PrecisionTree faz um par de recálculos no Excel enquanto analisa a árvore. Com uma árvore vinculada, PrecisionTree também faz um recálculo no Excel para cada caminho possível através da árvore (cada nó final).
  • Evolver faz um recálculo no Excel uma vez por teste.
  • StatTools faz praticamente todos os seus cálculos fora do Excel, assim, o ajuste do Excel terá pouco efeito sobre a velocidade das suas operações.
  • NeuralTools faz praticamente todos os seus cálculos fora do Excel, assim, o ajuste do Excel terá pouco efeito sobre a velocidade da rede de treinamento ou testes.

Microsoft tem uma série de sugestões de como obter um melhor desempenho fora de seu modelo de Excel:   

Data da última modificação: 2015-04-21


 


1.2. Utilizando as mesmas configurações para vários computadores

Available in English: Identical Settings for Multiple Computers
Disponible en español: Ajustes Iguales para Computadores Múltiples

Aplica-se a:
Todos os produtos, versões 5.x e 6.x

Pergunta:
Preciso garantir que todos os usários tenham as mesmas configurações para @RISK ou para qualquer um dos aplicativos do DecisionTools Suite. Isso é possível?

Resposta:
Sim, isso é fácil de ser feito. Este artigo vai lhe apresentar o procedimento detalhado para o @RISK, seguido pelas variações para os outros aplicativos.

Você pode criar um arquivo de política, RiskSettings.rsf, na pasta RISK5 ou RISK6 dentro de sua pasta de instalação Palisade. Se este arquivo de política estiver presente quando o @RISK for iniciado, o programa fará a importação em segundo plano das configurações do aplicativo e os usuários não serão capazes de alterá-las. Configurações do aplicativo, na verdade, incluem dois tipos de configurações:

  • Configurações Padrão de Simulação, tal como número de iterações, se as amostras de distribuição são coletadas, e se múltiplas CPUs estão habilitadas. Estas são aplicadas automaticamente a qualquer novo modelo que o usuário cria. No entanto, o usuário tem a capacidade de alterar as Configurações de Simulação e salvar o modelo com as configurações alteradas. Se o usuário abre um modelo existente, criado por esse usuário ou por outra pessoa, o @RISK irá utilizar as Configurações de Simulação armazenados com esse modelo, não as Configurações de Simulação padrão do arquivo de política.
  • Opções globais para o próprio @RISK, tal como para mostrar a tela de boas vindas e para salvar os resultados da simulação na planilha. Essas configurações são "congelados" pelo arquivo de política: o usuário não pode alterá-los, e eles não são afetados por qualquer coisa em uma pasta de trabalho.

Como criar um arquivo de política para o @RISK:

  1. Execute o @RISK, e no menu de Utilidades do @RISK e selecione Configurações do Aplicativo.
  2. Faça as alterações nas configurações que são exibidas. (Se uma Configuração de Simulação particular não for mostrada aqui, então esta versão do @RISK não permite definir um padrão.)
  3. Clique no ícone Reiniciar/Utilitários de Arquivo na parte inferior da janela, e selecione Exportar para Arquivo. Use o nome sugerido RiskSettings.rsf.
  4. Mova ou copie o arquivo para a pasta RISK5 ou RISK6 dentro da pasta de instalação Palisade do usuário.

Se você quiser fornecer um arquivo de configurações opcionais arquivo em vez de um arquivo de política obrigatória, crie o arquivo RiskSettings.rsf como anteriormente, mas não o coloque na pasta RISK5 ou RISK6. Os usuários poderão então importar as configurações abrindo as Configurações do Aplicativo, clicando no ícone Reiniciar/Utilitários de Arquivo e selecionando Importar do Arquivo.

Arquivos de política para outros aplicativos

O procedimento é o mesmo; apenas os locais dos arquivos de política mudam.

Configurações Nome do arquivo   Localização para 6.x                         Localização para 5.x

RiskSettings.rsf                                    RISK6                                                     RISK5

EvolverSettings.rsf                              Evolver6                                                Evolver5

NeuralToolsSettings.rsf                     NeuralTools6                                       NeuralTools5

PTreeSettings.rsf                                 PrecisionTree6                                    PrecisionTree5

RISKOptimizerSettings.rsf                                 (incorporada em RiskSettings.rsf)   RISKOptimizer5

StatToolsSettings.rsf                           StatTools6                                             StatTools5

(TopRank não suporta arquivos de política).

Data da última modificação: 2015-04-21

1.3. Removendo referências ultrapassadas para o Office a partir do Editor de Registro

Available in English: Removing Outdated References to Office from the System Registry
Disponible en español: Quitar referencias obsoletas de Office del Registro del Sistema

A remoção de uma versão do Microsoft Excel ou Microsoft Project, por vezes, pode deixar para trás as chaves "órfãs" no registro do sistema. Estas referências a produtos que já não estão instalados pode impedir o software Palisade de trabalhar corretamente com Excel, Project, ou ambos - você pode ver mensagens como "erro de automação: Biblioteca não registrada", "Erro ao carregar DLL", "Entre em contato com o aplicativo Microsoft Excel ", ou "O nome do arquivo ou classe nome não encontrado durante operação de automação".

Para remover as referências ultrapassadas, você precisará editar o registro do sistema, como detalhado abaixo. Se você prefere não editar o registro do sistema, ou se você não tem privilégios suficientes, você pode ser capaz de contornar o problema iniciando Excel em primeiro lugar e, em seguida, o software da Palisade. Se você gostaria de fazer com que o software Palisade iniciar automaticamente sempre que o Excel é iniciado, consulte Abrindo Palisade Software automaticamente sempre que o Excel abre. Caso contrário, proceder da seguinte maneira:

  1. Feche o Excel e Project.
  2. Clique em Iniciar > Executar, digite regedit e clique em OK
  3. Navegue até a chave: HKEY_CLASSES_ROOT \ TypeLib \ {00020813-0000-0000-C000-000000000046}. Dica: Clique no computador na parte superior do painel do lado esquerdo, em seguida, pressione Ctrl-F para abrir a janela de pesquisa. Verifique (assinale) a caixa de Chaves e desmarque as outras. Cole este comando na janela de pesquisa: {00020813-0000-0000-C000-000000000046}
  4. Clique no sinal de + à esquerda da {00020813-0000-0000-C000-000000000046} para expandi-lo. Você verá um ou mais subchaves: 1,5 para o Excel 2003, Excel 2007 para 1,6, 1,7 para o Excel 2010, Excel 1.8 para 2013. Identificar o(s) que não coincidem com a versão (s) de Excel que tem instalada.
  5. Você está prestes a excluir a chave (s) que correspondem às versões do Microsoft Excel que você não tem. Por razões de segurança, você pode querer apoiá-los em primeiro lugar. Botão direito do mouse em {00020813-0000-0000-C000-000000000046}, selecione Exportar e salve o arquivo em que você vai ser capaz de encontrá-lo.
  6. Clique com o botão direito do mouse na chave 1.algo que não lhe pertence, selecione Excluir e confirme a exclusão. Repita o procedimento para cada chave 1.algo que não lhe pertence.
  7. Navegue até a chave HKEY_CLASSES_ROOT \ TypeLib \ {2DF8D04C-5BFA-101B-BDE5-00AA0044DE52}.
  8. Dica: Clique no computador na parte superior do painel do lado esquerdo, em seguida, pressione Ctrl-F para abrir a janela de pesquisa. Verifique (assinalar) caixa de Chaves e desmarque as outras. Cole este comando na janela de pesquisa: {2DF8D04C-5BFA-101B-BDE5-00AA0044DE52}
  9. Clique no sinal de + para expandi-lo. Você verá um ou mais subchaves: 2.3 para o Office 2003, 2,4 para o Office 2007, Office 2010 para 2,5, 2,6 e 2,7 para o Office 2013. Identificar o(s) que não coincidem com a versão (s) do Office que você realmente tem instalado.
  10. Você está prestes a excluir a chave (s) que correspondem às versões do Microsoft Office que você não tem. Por razões de segurança, você pode querer apoiá-los em primeiro lugar. Botão direito do mouse em {2DF8D04C-5BFA-101B-BDE5-00AA0044DE52}, selecione Exportar e salve o arquivo em que você vai ser capaz de encontrá-lo. (Escolha um nome diferente para este arquivo, como Key2.)
  11. Clique com o botão direito do mouse na chave 2.algo que não lhe pertence, selecione Excluir e confirme a exclusão. Repita o procedimento para cada chave 2.algo que não lhe pertence.

 Essa chave {2DF8D04C-5BFA-101B-BDE5-00AA0044DE52} pode ocorrer em mais até três lugares:

  • (64-bit do Windows, com 32-bit ou 64-bit Excel) HKEY_CLASSES_ROOT \ Wow6432Node \ TypeLib \ {2DF8D04C-5BFA-101B-BDE5-00AA0044DE52}
  • (Todas as versões) do Windows HKEY_LOCAL_MACHINE \ SOFTWARE \ Classes \ TypeLib \ {2DF8D04C-5BFA-101B-BDE5-00AA0044DE52}
  • (64-bit do Windows, com 32-bit ou 64-bit Excel) HKEY_LOCAL_MACHINE \ SOFTWARE \ Wow6432Node \ Classes \ TypeLib \ {2DF8D04C-5BFA-101B-BDE5-00AA0044DE52}

Se você encontrou o primeiro através do diálogo Localizar no passo 7, você pode tocar a tecla F3 para chegar a cada um dos outros, por sua vez. Para cada um, repita os passos de 8 a 10 (clique no sinal de +, exportar a chave para um novo arquivo, e exclua as entradas 2.algo órfãs).

Feche o Editor do Registro. O software agora deve funcionar normalmente. Depois de verificar o @RISK (PrecisionTree, etc.) e o Excel independentemente do nosso software, você pode excluir os arquivos REG salvos.

Data da última modificação: 2015-04-21

 

 

1.4. "Há uma atualização disponível" (6.x)

Available in English: "An update is available." (6.x)
Disponible en español: "Hay Una Actualización Disponible" (6.x)

Aplica-se a: Todos os produtos, versões 6.2.1–6.3.1

Situação:
Assim que se abre o software Palisade, uma mensagem parecida aparece:

Há uma atualização disponível.

Uma versão do @RISK (versão 6.2.1) está disponível a partir de 13/03/2014.

Seu Plano de Manutenção permite que seu software receba as atualizações sem nenhum custo adicional, ou seja, gratuitamente.

Você deseja atualizar, mas precisa esperar pelo por alguém da TI para instala-lo. Ou talvez prefira não atualizar neste momento. Deseja que esta mensagem desapareça?

Solução:
Caso clique em "Não atualizar", um lembrete irá aparecer na próxima vez que você carregar o software, porém você pode adia-lo clicando em "Lembrar-me em 30 dias".

Caso queira que a mensagem desapareça por mais tempo, siga os passos abaixo:

  1. Clique no botão "Lembrar-me em 30 dias". (Esta é a forma mais fácil de criar uma chave no Registro do Sistema. Porém se seu software Palisade não está no momento sendo executado, você pode criar uma chave no passo no. 5 abaixo)
  2. Feche o Excel e o Project
  3. Clique no menu Iniciar e digite REGEDIT e pressione Enter no teclado.
  4. Navegue até HKEY_CURRENT_USER\Software\Palisade.
  5. No painel direito, você poderá ver uma chave chamada "SuppressProductUpdateMessages". Caso não esteja, clique com o botão direito do mouse em um lugar vazio do painel e selecione "Novo > DWORD"
  6. Dê um clique duplo na chave nova criada e entre um dia no formato de número inteiro, por exemplo: 41934 para 22 de outubro de 2014 ou 47848 para u último dia do ano de 2030.

O aviso de atualização não aparecerá mais até o dia configurado nesta chave de registro.

Last edited: 2015-06-17

1.5. Múltiplas Licenças - Qual será utilizada? (6.x/7.x)

Available in English: Which License Gets Used? (6.x/7.x)
Disponible en español:  ¿Qué licencia esta siendo utilizada? (6.x/7.x)

Aplica-se a:

Todas as licenças 6.x/7.x, clientes Standalone e de Rede

Pergunta:

Tenho mais de uma licença, possivelmente misturadas as de rede, Standalone e de testes (Trial). Por exemplo, se eu tenho uma licença do DecisionTools Suite e uma licença do @RISK, ou licenças do @RISK Industrial e @RISK Professional, o que determina qual licença será considerada ao abrir o @RISK?

Resposta:

O princípio geral é que cada componente da suíte se lembre de qual licença foi usada pela última vez para esse componente, e no caso, tentará reutilizá-lo quando você executar esse componente novamente. Esta memória é válida para cada componente separadamente, de modo que diferentes componentes da Suite podem usar licenças diferentes. Se há mais de um perfil de usuário (login do Windows) no computador, essa memória também se aplica a cada usuário separadamente, Cada licença lembrada pode ter modificação quando ocorre das seguintes situações:

  • Durante a instalação, se um ID de Ativação é digitado e o instalador é capaz de realizar uma ativação automática, todos os usuários serão então configurados para usar essa licença para todos os produtos abrangidos pela licença.
  • Se um usuário ativar uma licença através da janela de ativação do Gerenciador de Licenças, somente este usuário está definido para usar tal licença para tal produto. O mesmo acontece se o usuário selecionar uma licença disponível através da janela de Selecionar Licença no Gerenciador de licenças.

Tecnicamente, as licenças ativadas durante a instalação são lembrados em HKLocalMachine no registro do Windows, mas licenças ativadas ou selecionados a partir de dentro de um aplicativo são lembrados apenas em HKCurrentUser. Quando cada aplicativo é iniciado, ele usa um dos dois que fora modificado mais recentemente.

Alguns exemplos:

  1. Você tem o DecisionTools Professional (ativado) e @RISK Industrial (Trial), e instalou-os nesta ordem. Sempre que você executar o Evolver, NeuralTools, PrecisionTree, StatTools, ou TopRank, ele usará a licença do DecisionTools Suite Professional. Na próxima vez que você executar o @RISK, você receberá a licença de testes Industrial, mas você poderá mudar para a licença Professional ativada, clicando em Ajuda > Gerenciador de Licenças> Selecionar Licença.
     
  2. Você tem o @RISK (ativado), e você instalar uma versão de testes doDecisionTools Suite. Sempre que você executar o @RISK, Evolver, NeuralTools, PrecisionTree, StatTools, ou TopRank, ele usará a licença Industrial do DecisionTools Suite. Se você está preparando uma apresentação e quer evitar as marcas d'água da versão de testes em seus gráficos, você pode alternar o @RISK para a licença ativada clicando em Ajuda > Gerenciador de Licenças> Selecionar Licença. Depois disso, o @RISK vai continuar a usar a licença ativada, mas os outros componentes usarão a licença de testes (Trial).
     
  3. Você instala o @RISK sem ativá-lo, para que todos os perfis de usuários possam estar executando uma licença de testes. Mais tarde, você ativa o software. O @RISK vai se lembrar de usar a licença ativada para você, mas ele ainda se lembra da licença de testes à um outro usuário que executou o software na licença de testes. Esse usuário pode selecionar a licença ativada via Selecionar Licença no Gerenciador de licenças. Veja Um usuário não recebe a licença ativada (somente em Inglês)
     
  4. O Servidor Concorrente de Rede da sua empresa tem uma licença do @RISK Industrial, e você também tem uma do @RISK Professional ativado em seu computador como uma licença Standalone. Se você ativar a Professional e, em seguida, se conectar ao servidor, ao iniciar o @RISK da próxima vez, ele vai tentar usar a Licença de Rede Industrial. Se você ativar a licença Professional Standalone após a instalação de um cliente de rede, o @RISK vai utilizar a licença Professional ativada da próxima vez. De qualquer forma, você pode selecionar a outra licença via Ajuda > Gerenciador de Licenças> Selecionar Licença.

Pergunta seguinte:

E se a licença que eu estava usando ficar indisponível, ou seja, se a mesma expirar, ou se no caso seja uma licença simultânea de rede e todos os usuários concorrentes foram tomadas? Se eu tenho uma outra licença aplicável, o software irá usar esse automaticamente?

Resposta:

Automaticamente, não. Mas o software irá dizer-lhe que a licença não é mais utilizável. No Gerenciador de licenças, você pode clicar em Selecionar Licença, e selecione a outra licença. O software vai se lembrar de sua escolha da próxima vez.

Data da última modificação: 2015-06-08

2. @RISK: Perguntas Gerais

2.1. Compartilhar modelos do @RISK com colegas que não possuem @RISK

Available in English: Sharing @RISK Models with Colleagues Who Don't Have @RISK
Disponible en español: Compartir modelos de @RISK con Colegas que no poseen @RISK

Pergunta:
Tenho @RISK para Excel e gostaria de enviar minha planilha com resultados para um colega que possui Excel, porém não o @RISK. Consigo fazer isso?

Resposta:
Se você possui @RISK 5.0 ou posterior, seu colega não vai precisar de nenhum software especial. A função Swap Out Retirar as funções) faz com que seja bem fácil compartilhar pastas de trabalho com usuários que não possuem @RISK.

  • No @RISK 6.x, clique em Utilitários > Swap Out (Retirar as funções)
  • No @RISK 5.x, clique no ícone "Trocar Funções do @RISK" ou "Retirar as funções" no ícone que está no final do @RISK (Dependendo da versão 5.x do @RISK que possui. Isso pode ser visto pelo @ mais a marca /, através dela, ou pelo logotipo @RISK diante de uma das células na planilha.)

Depois de trocar as funções, as mesmas do @RISK serão substituídas por números. Salve a pasta de trabalho e seu colega poderá vê-lo no Excel sem quaisquer outros softwares. (Isso substitui o Visualizador de Planilhas que se usava com @RISK 4.x)

Ao voltar a abrir a Pasta de Trabalho, as funções deverão ser trocadas novamente de forma automática. Caso tenha dificuldades, por favor consulte Funções do @RISK que não voltam a aparecer depois de Retirar as funções (Swap Functions, somente em inglês).

Caso você tenha uma versão anterior do @RISK e deseja utilizar esta função, entre em contato com seu Gerente de Vendas da Palisade para obter a versão mais recente.

Pergunta de sequência:Quais números que o @RISK coloca nas células de funções de distribuições?

Resposta:@RISK 5.x irá mostrar valores estáticos das funções, tal como definido em (Ajustando do valor de retorno de uma distribuição, somente em inglês). Entretanto, ao solicitar a troca, pode-se abrir a janela de opções da Retirada das funções para anular o valor padrão para todas as funções que não possuam funções de propriedade RiskStatic definidas.

Data da última modificação: 2014-09-22

3. Velocidade do @ RISK

3.1. Para simulações mais rápidas

Available in English: For Faster Simulations
Disponible en español: Para simulaciones más rápidas

Aplica-se a:
@RISK 5.x e 6.x
(Para @RISK 4.x, verifique com o Suporte Técnico para acessar um artigo arquivado, em inglês.)

Pergunta:
Preciso melhorar o desempenho do @RISK. Tem alguma sugestão que possa ser feita?

Reposta:
Aqui você encontra uma lista de coisas que podem ser feitas dentro e fora do @RISK. As que mais fazem diferença estão marcadas em negrito.

Dicas para o Microsoft Excel:

  • Caso possua Excel 2007, instale o Service Pack mais recente. O SP1 melhora a velocidade do Excel e corrige alguns bugs. SP2 corrigiu bugs adicionais e melhorou a estabilidade do Excel. Após instalar algum Service Pack, execute a reparação de acordo com as instruções Reparando Excel ou Project.

  • Para simulações grandes representativamente, troque para a versão 64 bits do Excel 2010. Todas as versões antigas e a versão do Excel 2010 são limitadas até 2GB de RAM e com a memória virtual combinada. Excel 2010 de 64 bits não tem esse limite. (É necessário ao menos à versão do @RISK 5.7, caso tenha o Excel de 64 bits. Por favor, entre em contato com seu Gerente de Vendas Palisade caso necessite de uma atualização.) Por favor, observe: Excel de 64 bits permite que sejam executadas simulações grandes, mas não é essencialmente mais rápido que a versão de 32 bits.

  • Habilite cálculos em multi-thread (Excel 2007 e acima). No Excel 2010, Arquivo > Opções > Avançado > Fórmulas > Habilitar cálculo multi-thread.

  • No caso em que seu computador esteja executando Excel de uma rede, instale o Excel localmente. Isso elimina a lentidão por conta do tráfego da rede. (Caso você esteja executado o @RISK de um Servidor de Terminal, não seria o caso, já que todo o processamento ocorre no computador remoto.)

  • Para ter certeza de que o Excel esteja inicializando mais rápido, remova Suplementos desnecessários.

    • No Excel 2010, clique em Arquivo > Opções > Suplementos. Na parte superior direita, veja quais Suplementos e quais do tipo COM são desnecessários. Então, na parte inferior direita, após Gerenciar, selecione Excel ou COM e clique em Ir.
    • No Excel 2007, clique no botão redondo do Office, então em Opções do Excel > Suplementos. Então, na parte inferior direita, após Gerenciar, selecione Excel ou COM e clique em Ir.
    • No Excel 2003 ou abaixo, clique em Ferramentas > Suplementos. (Somente os Suplementos do Excel serão mostrados. Suplementos COM não estarão visíveis.)

    Remova a marcação dos Suplementos que não são necessários durante sua sessão do @RISK. Na próxima vez que você carregar o Excel e @RISK após fazer isso, quaisquer lentidões referentes ao carregamento desses Suplementos extras estarão eliminadas.

  • Siga as sugestões da Microsoft em Improving Calculation Performance (em inglês – acessado em 2014-01-09). Mesmo que o artigo referencie o Excel 2010, a maioria das sugestões se aplica para outras versões.

Dicas para o Windows e para seu computador:

  • Adicione memória RAM, a não ser que seu computador já tenha bastante. RAM insuficiente é provavelmente o maior gargalo para uma simulação. Verifique a luzinha de utilização do HD de seu computador enquanto se executa uma simulação. Se a mesma pisca constantemente durante a simulação, é porque há bastante atividade de leitura e escrita em seu HD, e você pode considerar inserir mais memória RAM em seu computador.

  • Deixe o Windows gerenciar a memória virtual (também conhecida como arquivo de paginação ou arquivo de troca). Confira Memória Virtual no artigo Sem Memória.

  • Esteja seguro que haja espaço em disco suficiente. Algumas aplicações e o próprio Windows se tornam bastante lentos caso não haja espaço em disco suficiente. (Desfragmentar seu disco pode ajudar, mas em versões recentes do Windows, é improvável que tenha efeito suficiente que fosse notado.)

  • Feche outras aplicações e serviços em segundo plano, tal como o Serviço de Indexação do Windows. Outros programas tomam ciclos do CPU do @RISK. Inclusive, a posse de memória pode fazer o Excel e o @RISK a trocar mais informação com o HD no modo de memória virtual, o que realmente traz um aumento na lentidão durante uma simulação.

  • Limpe a pasta de arquivos temporários. Maiores detalhes consulte Pasta Temporária do Windows no artigo Sem Memória.

  • Configure seu antivírus para não verificar arquivos .XLS ou XLSX. (Usando esse método, tenha cuidado para executar outros arquivos .XLS que você possa receber de uma pessoa qualquer.)

Dicas para seu modelo do @RISK:

  • Abra somente planilhas que fazem parte da simulação. Durante uma simulação, a cada iteração o Excel recalcula todas as planilhas abertas. Caso possua uma planilha desnecessária aberta, a mesma pode causar lentidão desnecessariamente.

  • Na barra de ferramentas do @RISK desmarque "Exibir Automaticamente Gráfico de Output", "Modo Demo", e "Recálculo Padrão Aleatório/Estático".

  • Remova elementos desnecessários de seu modelo;

    • Considere remover gráficos e tabelas de seu modelo. Essas podem tomar um tempo significativo para cálculos e atualizações.
    • Elimine links externos, caso possível, particularmente links para recursos de rede.
  • Caso você tenha funções do @RISK dentro de tabelas do Excel, mova-as para fora. Para maiores detalhes, consulte Excel Tables and @RISK (em inglês).

  • Caso suas distribuições RiskCompound() contenham somente referências de células com as distribuições atuais em outras células, a simulação poderá ser notavelmente bem mais rápida se você inserir as distribuições atuais de severidade dentro de RiskCompund(). (Não é importante para distribuições de frequência, apenas para distribuições de severidade.) Quando mais funções RiskCompound() você tiver em seu modelo, mais fará diferença. Confira Combining Probability and Impact (Frequency and Severity) (em inglês) para maiores informações sobre RiskCompound( ).

  • Não salve os resultados de suas simulações dentro de sua planilha, ou caso você faça, limpe-os antes de iniciar a simulação. Salvar os resultados causará o Excel a tomar mais tempo para calcular cada iteração. Quanto mais diferenças isso faz, depende do tamanho dos resultados. Confira: Files with @RISK Grow Too Large (em inglês).

Dicas para as Configurações de Simulações do @RISK:

  • Aba Geral: Configure Suporte para múltiplos CPUs para "Ativado". Se seu processador é de duplo núcleo, ou quádruplo núcleo, etc. Começa pelo @RISK 5.5, disponível em todas as edições do @RISK, não somente na Industrial. Caso você possua @RISK Professional ou Standard e você possui processador de quatro núcleos, ou mais, provavelmente verá aumento significante na velocidade caso atualize para Industrial.

    Em raras situações caso você possua uma grande quantidade de CPUs, a sobrecarga do processamento paralelo podem exceder os ciclos de CPU compartilhada. Ou, com todas as CPUs compartilhando uma quantidade fixa de RAM, você poderá notar que a memória virtual usa muito mais trocas no disco e diminui a velocidade da simulação. Neste caso, reduzir a quantidade de CPUs disponíveis para o @RISK poderá ajudar. Infelizmente, não há como prever isso, a você deverá experimentar depois de ter tentado outras dicas. Para instruções, confira CPUs Used by @RISK (em inglês).

    Simulações com o Microsoft Project não podem usar CPUs múltiplos. Se a configuração de múltiplos CPUs de sua simulação estiver habilitada, a mesma automaticamente se desabilitará ao clicar em Iniciar Simulação quando a mesma estiver sob o Project.

  • Guia Visualização: Desative a atualização automática durante a simulação. Desmarque Exibir Recálculos do Excel.

  • Guia Amostras:

    • Configure Tipo de Amostragem para "Latin Hypercube" (configuração padrão). Particulamente, se você estiver testando para convergência, essa configuração irá melhorar a velocidade da simulação. Exceção: se você selecionar as iterações em milhões, Latin Hypercube irá reduzir a velocidade da simulação, sendo melhor configurar em "Monte Carlo". Entretanto isso é usado em modelos bem raros nos quais se usam milhões de iterações no modo Latin Hypercube.
    • Configure a Coleta de Amostras de Distribuições para "Nenhum" ou "Inputs marcados com Coleta". Para implicações, confira Coletando Distribuições de Inputs no artigo Sem memória.
    • Desative Análise de Sensitividade Inteligente. Isso não melhorará as iterações, mas pode significantemente melhorar a inicialização da simulação. Para o entendimento da Análise de Sensitividade Inteligente e as implicações em desabilita-la, confira Precedent Checking (Smart Sensitivity Analysis) (em inglês).
    • Ajuste a Atualização das Funções Estáticas para "Ao fim de cada simulação". (Isso é padrão no @RISK 5.5 e acima, e não disponível no @RISK 5.0.) Isso aumentará consideravelmente a velocidade de sua simulação, caso tenha um monte de funções estáticas como RiskMean e RiskPercentile. Além do aumento da velocidade, pode haver boas razões lógicas para escolher esta definição, no entanto, os resultados da simulação podem ser diferentes das versões anteriores do @ RISK. Confira Mensagem: "No values to graph" Message / All Errors in Simulation Data (em ingles).
  • Aba de Convergência: Considere habilitar o teste de convergência. Caso você esteja executando mais interações que o necessário, você vai desperdiçar muito tempo com a simulação. Por outro lado, testando-se a convergência envolve menor sobrecarga. Tente testar a convergência e veja se a simulação converge em menos tempo significante do que tomava antes. Caso o faça, deixe o teste de convergência habilitado. De outra maneira, volte para um número fixo de iterações. (Quando você habilita o teste de convergência configure também o número de iterações para "Automático" na aba Geral e selecione "Latin Hypercube" na aba de Amostragem.)

Dicas para a janela de progresso da simulação:

Perceba no número de iterações por segundo. Ele deve aumentar durante a primeira parte da simulação e em seguida, considerando que não haja nenhum outro programa "pesado" em processo de abertura, deve se manter estável.

Porém em muitas vezes, caso o Excel não esteja selecionado como o programa em primeiro plano, o número de iterações por segundo irá cair gradualmente e a simulação se tornará cada vez mais lenta. Neste caso, coloque o Excel em primeiro plano, clicando em sua janela uma vez. Você perceberá que o número de iterações irá crescer gradualmente.

Nem sempre isso acontece assim, e não é exatamente claro qual a interação entre o Excel e o Windows reage essa interação quando a queda de rapidez acontece. Porém, dar prioridade na janela do Excel, geralmente minimiza os impactos da queda de velocidade de uma simulação.

Dicas para @RISK com Projetos (@RISK Professional e Industrial):

  • Atualize para a versão mais atual do @RISK caso você possua o @RISK 6.0. O sistema de motor acelerado introduzido no @RISK 6.1 faz com que muitas simulações com projetos sejam executadas bem mais rapidamente.

  • Use o sistema de motor acelerado. No menu Project > Configurações do Project > Simulações, assegure-se de que o sistema de motor acelerado está configurado como Automático, e o @RISK irá usar esse sistema, caso seu modelo que seja compatível. Se você notar que o @RISK ainda persiste com o motor padrão, seu modelo pode conter recursos que não são compatíveis com o sistema de motor acelerado. Clique no botão Verificar Motor na mesma janela, e @RISK irá listar os problemas de recursos de seu modelo. Caso você modifique sem que se perda funcionalidades essenciais, sua simulação poderá executar-se muito mais rapidamente. Para mais detalhes, veja os tópicos "Motor de Simulação" e "comando de Verificar o Motor" no arquivo de ajuda do @RISK.

  • Caso tenha experiência com o @RISK 4, você pode ter usado uma ramificação probabilística. Isso consome intrinsicamente o tempo em que as modificações sejam feitas pelas relações de percussor/ sucessor a cada iteração, e o reinício para a próxima iteração. No @RISK 6 esses problemas são ampliados pela comunicação entre o Excel e o Project. Para incorporar eventos de risco, considere um registro de risco do que uma ramificação probabilística. Para exemplos, clique em Ajuda, Planilhas de Exemplo > Gerenciamento de Projetos.

  • Caso possua Project 2007, mude-o para 2010 ou preferencialmente ao 2003. Os recálculos de projetos do Project 2007 são mais lentos. Veja Simulation Speed of @RISK with Microsoft Project (em inglês).

  • Em Configurações do Project > aba Simulação, caso você não precise da informação de Cálculo Crítico dos Índices, e Coletar informação de escala de tempo, desmarque essas opções.

  • Em Configurações do Project > aba Simulação, ajuste o Período de Simulação para "Atividades após a data do projeto atual" ou "Atividades após data de status do projeto". Isso fará sua simulação rodar mais rapidamente, pois o @RISK não irá simular as tarefas que já estejam completadas.

  • Não reimporte arquivos .MPP (@RISK Professional e Industrial). Você só vai precisar importar o arquivo .MPP uma vez e armazenar a planilha do Excel quando o @RISK lhe perguntar. Após isso, no @RISK não abra o arquivo .MPP diretamente. Quando você abrir uma planilha do Excel associada a um projeto, o @RISK irá automaticamente conectar-se ao arquivo .MPP automaticamente e irá usar quaisquer modificações para atualizar a planilha. Isso toma muito menos tempo que reimportar de um rascunho.

Dicas para Microsoft Project:

  • Caso o projeto esteja em uma unidade de rede, copie-o para seu disco local (mais otimizável possível em um SSD) antes de abri-lo.

  • Retire os vãos de margens.

  • Configure as constantes futuras para "O mais rápido possível".

  • Remova todas as datas limites.

  • Verifique a margem de atraso negativa, as tarefas sem status, e corrija quaisquer problemas.

  • Crie uma tabela que contenha somente os campos que você deseje ver no @RISK, e aplique isso antes de importar o projeto.

Dicas para RISK Optimizer (@RISK Professional and Industrial):

Consulte For Faster Optimizations (em inglês).

Data da última modificação: 2015-12-22

4. Performance do @RISK

5. RISKOptimizer e Evolver