HomeConfiguração do usuário finalComponentes opcionaisVersões e instalações do SQL

4.2. Versões e instalações do SQL

Available in English: Available in English: SQL Versions and Installation
Disponible en español: Versiones de SQL e instalación

Aplica-se a:
@RISK 5.x, 6.x, 7.x

Pergunta:
Qual versão do SQL eu devo instalar para funcionar com o @RISK? É necessário uma instalação local, ou posso conectar a um servidor remoto?

Resposta:
Você poderá ou não necessitar de instalar o SQL. O recurso da Biblioteca do @RISK é a única dependência do @RISK no SQL. Confira em SQL - Preciso instala-lo? Para usar o recurso da Biblioteca do @RISK, escolha a seção correta abaixo, pois muitas mudanças foram feiras para a versão do @RISK 6.2

SQL com @RISK 6.2 e superiores:

A Biblioteca do @RISK pode estar em seu computador local, em computadores remotos ou os dois juntos. Caso você queira criar e usar bibliotecas no seu computador local, ou caso queira criar e usar bibliotecas em um servidor, ou outro computador você precisa ter um software compatível para o SQL Server instalado nos mesmos. Caso não queira gravar bibliotecas do SQL no seu computador local, não há necessidade de instalar localmente o SQL. Em outras palavras, o programa no servidor SQL necessita estar em um computador que hospeda uma base de dados SQL, mas não necessariamente em um computador que cria, atualiza ou leia essa base de dados.

Quaisquer softwares Microsoft SQL Server 2005 ou superior, incluindo o Server Express gratuito, funcionará com o @RISK 6.2. No Windows de 32 bits, instale o SQL de 32 bits. No Windows de 64 bits, já foi visto funcionar o SQL tanto a versão de 32 bits, quanto à de 64 bits no @RISK sob Excel de 32 ou 64 bits. Ou seja, a questão de arquitetura de bits não faz referência com a arquitetura do Excel.

Como exemplo, confira no link a seguir a versão 2008 do Server Express com instruções detalhadas para instalação: http://www.palisade-br.com/support/SQLServer.asp. Veja que, entretanto não há a necessidade de a atualização de compatibilidade com versões anteriores que é mencionado no link. Desta forma,  não há limitação pela versão do SQL.

SQL com @RISK 6.1 e anteriores:

O recurso da Biblioteca do @RISK funciona por uma instalação local do SQL, mesmo que todas as bases de dados de sua Biblioteca do @RISK estejam em um computador remoto. Isso significa que uma versão compatível do SQL esteja listada em Programas e Recursos ou Adicionar ou Remover Programas no Painel de Controle do Windows, na mesma lista que @RISK ou o The DecisionTools Suite. Em contrapartida ao programa do SQL, a base de dados pode estar localmente, remotamente, ou os dois juntos.

Testamos @RISK 5.x e 6.x com Microsoft SQL Server 2005 Express e Microsoft SQL Server 2008 Express. Todos esses SQLs funcionam para essas versões do @RISK. Detalhes abaixo:

  • O Microsoft SQL Server 2008 Express acompanha as versões de 32 e 64 bits. E caso você possua versão 64 bits do Excel, você deve usar a versão de 64 bits. Veja nesse link: Como saber de quantos bits é o seu sistema operacional (32 ou 64).

    Para instalar o Microsoft SQL Server 2008 Express, use esse link: http://www.palisade-br.com/support/SQLServer.asp

    O SQL Server 2008 Express requer a Atualização De Compatibilidade Com Versões Anteriores, no qual é necessário instalar através do mesmo link.

  • Para instalar o Microsoft SQL Server 2005 Express, use esse link, mesmo possuindo as versões de 32 bits ou 64 bits do Windows: http://www.palisade.com/support/sql92847.asp

  • Não é necessário instalar a versão Express. Quaisquer versões completas do Microsoft SQL 2005 ou superior são suficientes, mesmo que não tenhamos testado todas as mesmas. Se você instalar o Server 2008 ou superiores, a Atualização De Compatibilidade Com Versões Anteriores será necessária.

Data da última modificação: 2015-06-11

This page was: Helpful | Not Helpful