HomeTroubleshootingAll Products: Startup"The current system code page is incompatible with this program."

2.75. "The current system code page is incompatible with this program."

Applies to: All Palisade software, releases 6.0–7.0 only

When launching the software, I get the message

The current system code page is incompatible with this program. Please see the readme file for more information.

The program then opens, but the text is unreadable.

Your best solution, if you have a current maintenance contract, is to upgrade to the latest version. Starting with 7.5.0, @RISK has improved Unicode support so that code pages are no longer a concern. However, if you don't have a maintenance contract and don't want to purchase an upgrade, you can use the following solution.

Non-English editions of the Palisade DecisionTools releases through 7.0.1 required the correct Windows "code page". For example, to use the Japanese version, Windows must have the active code page set to Japanese. If you are running on Japanese Windows, this will automatically be set by default. However, if you are running a Japanese Palisade add-in on a non-Japanese machine, you will need to change the default Windows code page.

To change the code page in Windows 8, Windows 7, and Windows Vista:

  1. Open Control Panel » Region and Language. (It's just Region in Windows 8.)
  2. Select the Administrative tab.
  3. Click the button "Change system locale ..." and select the correct language.

To change the code page in Windows XP:

  1. Open Control Panel » Regional and Language Options.
  2. Select the Advanced tab.
  3. Under "Language for non-Unicode programs", select the correct language.

Additional keywords: Chinese, French, German, Portuguese, Russian, Spanish

Last edited: 2016-07-12

This page was: Helpful | Not Helpful