HomeTroubleshootingAll Products: Startup"... requires Excel 2007 or higher."

2.17. "... requires Excel 2007 or higher."

Applies to:
All products, release 7.0.0 or newer

I launch my Palisade software, and I get one of these messages:

@RISK requires Excel 2007 or higher.

BigPicture requires Excel 2007 or higher.

Evolver requires Excel 2007 or higher.

NeuralTools requires Excel 2007 or higher.

PrecisionTree requires Excel 2007 or higher.

StatTools requires Excel 2007 or higher.

TopRank requires Excel 2007 or higher.

Beginning with release 7.0.0, @RISK and our other software require an Excel version that uses the ribbon, rather than the older-style menus. If you're actually running Excel 2003 or earlier, you need to upgrade to a more recent Excel. You'll find a full list of compatible versions in Windows and Office Versions Supported by Palisade.

But I actually do have a later version of Excel!

In that case, please work through this checklist:

Last edited: 2017-08-31

This page was: Helpful | Not Helpful